Many reported Fascard server communication issues
Incident Report for Card Concepts Inc.
Resolved
This incident has been resolved.
Posted Nov 20, 2024 - 10:20 CST
Investigating
We are currently investigating this issue.
Posted Nov 20, 2024 - 08:27 CST
This incident affected: FasCard / FLEX (Satellite Connectivity).